Wednesday, April 6, 2016

Episerver Block Controller error

I am expanding my horizons in the CMS world to add Episerver to the list of platforms I develop on, and the process is a bit of trial-and-error, with an emphasis on the "error" part the past couple weeks. I am coming into this without attending any Episerver training, so this may be known to everyone else, but, nevertheless, I found this error rather intriguing and wanted to share in case someone else missed the cause due to lack of coffee.

I am building a site using MVC, and with that comes the creation of a block class, and a block controller. I added my block to my Page model and then proceeded to create the controller. Using the standard approach in Episerver, I named the controller and block to match, with the block called CalloutBlock, and the matching controller CalloutBlockController. After copying some code into my controller, building, and refreshing my page, I was greeted with the following, lovely message:

Monday, April 4, 2016

Missing Templates with Email Campaign Manager in Sitecore 7.5

I have been working with debugging some Sitecore issues as of late and they have all seemed to deal with modules or packages being installed. Frustratingly, it seems like there is a different outcome among instances when I install a module on a Test server, and install the same module into a clone of a site on my local development, or another developer's machine. The latest culprit is the Email Campaign Manager (ECM).

Installed into a Staging server, the ECM module worked fine, allowing us to go through and create messages and test the system. However, I installed the same exact package into my local development environment, that was basically a clone of Staging, and when I went to create a message, the template options were empty.